Pay in installments of $8.25 with
,
and
Shipping Estimate
USA
- USA
- CAN
- USA
- CAN
Ships within 48 hours · Estimated delivery Oct 3 - Oct 8
For Your Every Summer RSVP, with Code: SUMMER15
Description
Tp-Link 300mbps Wireless N VDSL/ADSL Modem Router Td-W9970HARDWARE FEATURES Interface 4 10 100Mbps RJ45 Ports1 RJ11 Port1 USB 2. 0 Port Ports 1 10 100 Mbps LAN WAN Port, 3 10 100 Mbps LAN ports, 1RJ11 port, 1 USB 2. 0 Port Button 1 Power On Off Button1 WPS RESET Button1 Wi Fi On Off Switch External Power Supply 12VDC 1A IEEE Standards IEEE 802. 3, 802. 3u VDSL2 Standards ITU T G. 993. 2ITU T G. 993. 5 (G. vector)ITU T G. 998. 4 (G. INP ADSL Standards Full rate ANSI T1. 413 Issue 2ITU T G. 992. 1(G. DMT)ITU T
| HARDWARE FEATURES | |
|---|---|
| Interface | 4 10/100Mbps RJ45 Ports 1 RJ11 Port 1 USB 2.0 Port |
| Ports | 1× 10/100 Mbps LAN/WAN Port, 3× 10/100 Mbps LAN ports, 1× RJ11 port, 1× USB 2.0 Port |
| Button | 1 Power On/Off Button 1 WPS/RESET Button 1 Wi-Fi On/Off Switch |
| External Power Supply | 12VDC/1A |
| IEEE Standards | IEEE 802.3, 802.3u |
| VDSL2 Standards | ITU-T G.993.2 ITU-T G.993.5 (G.vector) ITU-T G.998.4 (G.INP) |
| ADSL Standards | Full-rate ANSI T1.413 Issue 2 ITU-T G.992.1(G.DMT) ITU-T G.994.1 (G.hs) ITU-T G.995.1 |
| ADSL2 Standards | ITU-T G.992.3 (G.dmt.bis) |
| ADSL2+ Standards | ITU-T G.992.5 |
| Dimensions ( W x D x H ) | 7.7*5.1*1.4 in. (195×130×36mm) |
| Antenna | 2 × 4dBi Fixed Omni-Directional Antennas |
| Antenna Type | Omni directional, Fixed |
| Antenna Gain | 2 x 5dBi |
| WIRELESS FEATURES | |
|---|---|
| Wireless Standards | IEEE 802.11b, 802.11g, 802.11n |
| Frequency | 2.400-2.4835GHz |
| Signal Rate | 300 Mbps at 2.4 GHz |
| Transmit Power | <20dBm(EIRP) |
| Wireless Functions | Enable/Disable Wireless Radio, WMM, Wireless Statistics |
| Wireless Security | Support 64/128 bit WEP, WPA /WPA2, WPA-PSK/WPA2-PSK Wireless MAC Filtering |
| SOFTWARE FEATURES | |
|---|---|
| Quality of Service | WMM, Bandwidth Control (IP QoS) |
| Security | NAT Firewall, SPI Firewall, MAC / IP / URL Filtering |
| IPv6 | IPv6 and IPv4 dual stack Supported IPv6 Tunnels: DS-Lite, 6RD, 6 to 4 Supported IPv6 Connection Type: PPPoEv6, DHCPv6, Static IPv6 |
| Operating Modes | DSL Modem Router, 3G/4G Router, Wireless Router |
| Management | Web Based Configuration(HTTP), Remote management, Telnet management, Command Line Interface, SSL for TR-069, SNMP V1/V2C, Web Based Firmware Upgrade, CWMP(TR-069), Diagnostic Tools |
| DHCP | Server, Client, DHCP Client List, Address Reservation, DHCP Relay |
| Port Forwarding | Virtual server, Port Triggering, UPnP, DMZ, Manage Control |
| Dynamic DNS | DynDns, NO-IP |
| VPN Pass-Through | PPTP, L2TP, IPSec Pass-through |
| Protocols | Supports IPv4 and IPv6 |
| ATM/PPP Protocols | ATM Forum UNI3.1/4.0 PPP over ATM (RFC 2364) PPP over Ethernet (RFC2516) IPoA (RFC1577/2225) PVC - Up to 8 PVCs |
| Advanced Features | Ethernet WAN (EWAN) Guest Network, Wireless Schedule Parent Control Traffic Shaping(ATM QoS) UBR, CBR, VBR-rt, VBR-nrt; Dynamic Host Configuration Protocol (DHCP), DHCP relay; Network Address Translation (NAT); PVC/Ethernet Port Grouping Static Routing, RIP v1/v2 (optional); DNS Relay, DDNS, IGMP snooping V1/2 IGMP Multicast, UPnP |
| USB Sharing | Storage Sharing FTP Server Media Server Print Server |
| Guest Network | 2.4 GHz Guest Network |
| IGMP | IGMP snooping V1/V2/V3 IGMP Multicast |
| IPSec VPN | 10 IPSec VPN Tunnels LAN-to-LAN Main, Aggressive Negotiation Mode DES, 3DES, AES128, AES192, AES256 Encryption Algorithm MD5, SHA1 Authentication Algorithm Manual, IKE Key Management Mode Dead Peer Detection (DPD) Perfect Forward Secrecy (PFS) |
| OTHERS | |
|---|---|
| Certification | CE, RoHS |
| Package Contents | TD-W9970 External Splitter RJ-11 Telephone Line RJ-45 Ethernet Cable Quick Installation Guide Resource CD Power Adapter |
| System Requirements | Windows 10/8.1/8/7/Vista/XP or Mac OS or Linux-based operating system |
| Environment | Operating Temperature: 0~40 (32~104) Storage Temperature: -40~70 (-40~158) Operating Humidity: 10%~90% non-condensing Storage Humidity: 5%~90% non-condensing |
Shipping Notes
- Free Standard Shipping on $100+ Orders to the USA.
- Except Preorder products are shipped in 48 hours.
- Delivery to the USA:
- Standard Shipping : 3-10 business days
- If time is of the essence, please consider selecting expedited delivery for faster service.
Exchange/Return Notes
- We offer a 30-day return/exchange service after receiving.
- Final sale items are not eligible for returns or exchanges.
- To process your return/exchange, please contact us at [email protected]
- Please click here for more details>>> Return & Exchange Policy
4.8 ★★★★★
Based on 22 reviews
Sort
Product Reviews
★★★★★ 5
Highly recommend these shelves
Color: Black, Size: 2 Pack
Love these shelves! Easy to put up, stylish, well made and mounting hardware feels secure. Love the fine details of the included screws and anchors and small tabs to cover screws underneath.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on May 27, 2026
★★★★★ 4
Stylish and affordable!
Color: Grey, Size: 4 Pack, Color: Grey, Size: 4 Pack
These shelves are rey stylish, light and durable! The set came with everything needed to install. The color is just as described. Price is steal and these shelves can definitely be used anywhere throughout the house. I did give it only 4 stars because as you can see in the photos, the underneath was not completely finished. Decided to keep because the price was unbeatable.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on April 5, 2026
★★★★★ 5
Great shelves
Color: Mahogany, Size: 2 Pack
Love these! Easy install and they look great. Very sturdy.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on May 14, 2026
★★★★★ 5
Easy to Hang
Color: Black, Size: 3 Pack
This shelf is easy to hang, comes with great anchors and looks perfect. The quality looks nice and is was an easy hanging process compared to other shelves. Worth it for the price.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on May 18, 2026
★★★★★ 5
One of the best deals available!
Color: White, Size: 2 Pack
Extremely sturdy, good looking and easy to install. I have a couple of dozen feet of assorted lengths in the kitchen, bedroom, living room and foyer. Holding all sorts of antique clocks, audio equipment and cooking stuff from my flours and assorted cornmeals to cases of powdered “lemonade”.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on April 18, 2026
recommand products
Wera 005523 8790 B 13/16" Impaktor Socket, 3/8" Drive, 6 Point
10.50
Wera 051012 9650 Magnetic Rail Kraftform Screwdriver Set, 9 Pieces
100.32
Shimano XT HB-M756 Front Hub - QR x 100mm, 6-Bolt, Black, 32h
50.87
Hazet 811BML 1/4" Magnetic Bit Holding Screwdriver with 3K Handle, 205 mm
29.52
Shimano Snap Ring for Disc Brake Pad Axle
12.41