SKU: 87438275118

WINSTAR WIRELESS AC1300M DUAL BAND USB 3.0 ADAPTER

Sale price$35.10 Regular price$39.00
Save 10%

Pay in installments of $9.75 with ShopPay, AfterPay and Klarna

Shipping Estimate
USA
  • USA
  • CAN

Ships within 48 hours · Estimated delivery Oct 3 - Oct 8

Promo Codes Available:

For Your Every Summer RSVP, with Code: SUMMER15

Description

WINSTAR WIRELESS AC1300M DUAL BAND USB 3.0 ADAPTERFeatures 1300 (867+400)Mbps wireless speed Support 2. 4GHz & 5GHz WLAN networks Dual Band connections for lag free HD video streaming and gaming SuperSpeed USB 3. 0 port, backward compatible to USB 2. 0 Complies with IEEE 802. 11ac, IEEE 802. 11n, IEEE 802. 11g, IEEE 802. 11b standards 20MHz & 40MHz & 80MHz bandwidth transmission OFDM with BPSK, QPSK, 16QAM, 64QAM, 256QAMmodulation Supports Windows XP Vista 7 8 8. 1 10, MAC Specification Hardware

Features

1300 (867+400)Mbps wireless speed

Support 2.4GHz & 5GHz WLAN networks

Dual Band connections for lag-free HD video streaming and gaming

SuperSpeed USB 3.0 port, backward compatible to USB 2.0

Complies with IEEE 802.11ac, IEEE 802.11n, IEEE 802.11g, IEEE 802.11b standards

20MHz & 40MHz & 80MHz bandwidth transmission

OFDM with BPSK, QPSK, 16QAM, 64QAM, 256QAMmodulation

Supports Windows XP / Vista / 7 / 8 / 8.1/10, MAC

Specification

Hardware 

Ports: USB 3.0

Button: WPS 

LED: 1 X Link/ Active

Chipset:RTL8812AU 

Flash: N/A 

SDRAM: N/A 

Power Supply: USB 5V 

Power Plug: N/A 

Power Consumption:

Rated Voltage/ requency /current:DC 5V about 500mA

Wireless 

Standard:IEEE802.11ac,IEEE 802.11a, IEEE 802.11b,IEEE 802.11g,IEEE 802.11n

Modulation:

11ac\n: 16QAM, 64QAM 128QAM 256QAM with OFDM

11g: BPSK, QPSK, 16QAM, 64QAM, OFDM

11b: DQPSK, DBPSK, DSSS, CCK 

Speed:

802.11ac: up to 867Mbps 

802.11n: up to 400Mbps 

802.11a: up to 54Mbps 

802.11g: 54 M 

802.11b: 11 M 

Frequency band:5GHz and 2.4GHz 

Power: 

802.11b: 22dBm ± 2 dBm 802.11g: 16dBm ± 2 dBm 

802.11n: 15dBm ± 2 dBm 802.11ac: 14dBm ± 2 dBm 

Distance:Outdoors 300m, Indoor 100m(According to the actual environment change)

Safely 64/128-bit WEP, AES,TKIP,WPA,WPA2,802.1x,WPA-PSK,WPA2-PSK,MAC, WDS

Environmental 

Operating Temperature:0ºC~40ºC 

Storage Temperature:-10~70  

Relative Humidity(Operational): 10%~90%,noncondensing 

Relative Humidity(Storage):10%~90%,noncondensing

Software

Standard Version 

RFC768 User Datagram Protocol(UDP)

RFC791 Internet Protocol(IP) 

RFC792 Internet Control Message Protocol

RFC793 Transmission Control Protocol(TCP)

bandwidth 20MHz & 40MHz & 80MHz

Wireless Mode 11ac only, 11n only, 11g only & 11b only(option)

System Windows XP / Vista / 7 / 8 / 8.1/10, MAC

Product weight and dimensions

Item Weight: 0.25 KG

Product Dimensions: 98mm L x 28mm W x 10mm (L x W x H)

Package content

1 x Wireless-AC USB3.0 Aapter

1 x Quick Installation

1 x CD driver

Shipping Notes
  • Free Standard Shipping on $100+ Orders to the USA.
  • Except Preorder products are shipped in 48 hours.
  • Delivery to the USA:
  1. Standard Shipping : 3-10 business days
  • If time is of the essence, please consider selecting expedited delivery for faster service.
Exchange/Return Notes
  • We offer a 30-day return/exchange service after receiving.
  • Final sale items are not eligible for returns or exchanges.
  • To process your return/exchange, please contact us at [email protected]
  • Please click here for more details>>> Return & Exchange Policy
SKU: 87438275118

Discover Niche Categories That Outsell

Top-Converting Item to Boost Your Average Order

4.7 ★★★★★
Based on 20 reviews
Sort
Highest Rating
Newest First
Oldest First
Product Reviews
R
Verified Purchase
rilakk
Dallas, US
★★★★★ 4
Fun read
Format: Kindle
I'm not really into mafia books but I love Roxy Collin's other series so I decided to give it a try. It had the same great romance, spice, swoon-worthy characters and exciting plot that are her signature. Arben was my favorite, although it was a bit sudden how quickly he changed from ignoring her to wanting to be pack. There were almost too many twists/layers of lies to keep track of but I'm looking forward to reading the other books. The only thing that detracted from the story for me was the need for a bit more proofreading. It was mentioned that Kelly is a female and male at different points, leading me to think she changed her mind at some point about the character's gender but didn't go back and edit it to align in all places. Like another reviewer pointed out, step siblings are different than half siblings. They are incorrectly referred to as step siblings because they (allegedly) share the same biological dad. There are a few other typos as well but those aren't a big deal.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on March 18, 2025
C
Verified Purchase
Carmen Alicea
Carnegie, US
★★★★★ 5
Stepbrothers, Secrets, and Sizzling Heat
Format: Kindle
Twisted Lies by Roxy Collins is a wild ride through family secrets, amnesia, and a steamy stepbrother romance. When Kelly discovers her life is built on lies, she ends up tangled with three alpha stepbrothers and an assassin who once helped her through a heat. The tension? Off the charts! The heat is real, and the complications are messy in the best way. Full of twists, secrets, and fated mates? You'll be hooked from page one! Love omegaverse drama with a dash of taboo? This one's for you!
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on September 10, 2024
A
Verified Purchase
Ashley
Massapequa, US
★★★★★ 3
Good read
Format: Kindle
The book has some good twists and turns, but truthfully I was so confused on some things. It didn't have a good flow for me personally. Not sure if it's due to typos or using him/her wrongly, but I thought Kelly was both a guy and a girl. Actually I still don't know, and it made me incredibly frustrated. It would refer to Kelley as him or he, and then again in another part of the story as her she and sister. On to the next book, I hope there is some clarity and a smoother flow. This is a slow burn, and I just don't know how much I care for the Alphas yet. Idk if I recommend.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on February 8, 2023
S
Verified Purchase
75_SweetestBook
Cuba, US
★★★★★ 5
the lies
Format: Kindle
This is amazing fast pace read that is full of plot twists and lies that keep getting bad. This is a story we’re a omega has been lied to by her mother and finds out that someone is slowing dieing. 3 alpha take the omega and feed her more lies so they can use her against her father so they can find their mate Kelly. This is a dark read and ends in a cliffhanger and so good.
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on June 13, 2023
T
Verified Purchase
trinityknt7
Pawtucket, US
★★★★★ 4
Hot twists
Format: Kindle
This will keep you on your toes toes in a hot twisty mess. You want to love, hate and root for whom is the big question. I’m quickly getting the next book because it ends on a cliffhanger and damn, it’s got me ready to tear into it!
WAS THIS REVIEW HELPFUL?YesReportShare
Reviewed in the United States on February 16, 2026

recommand products